Click Tracking Links
Incident Report for ReviewMonitoring.com
Resolved
Our engineering team identified the issue. Click and Open Links services are slowly being restored. We're continuing to monitor performance.
Posted almost 3 years ago. May 01, 2016 - 12:20 EDT
Update
Our engineering team is still working hard to investigate the root cause of click and open tracking not resolving.
Posted almost 3 years ago. May 01, 2016 - 11:39 EDT
Investigating
Our engineering team is currently investigating reports of Click Tracking links not resolving. We will update with more information shortly.
Posted almost 3 years ago. May 01, 2016 - 10:11 EDT