User login/password
Incident Report for ReviewMonitoring.com
Resolved
This incident has been resolved. Thank you for your patience.
Posted over 2 years ago. Sep 29, 2016 - 14:56 EDT
Identified
We've identified an issue with 30% of our users unable to login to their accounts via username and password. Please reach out to our support at hi@reviewmonitoring.com for a direct auto-login link. We will update once the issue has been resolved. We apologize for the inconvenience.
Posted over 2 years ago. Sep 29, 2016 - 13:40 EDT