Email Delays
Incident Report for ReviewMonitoring.com
Resolved
The vast majority of the delayed mail has completely dequeued, and all incoming mail is being processed as normal. Thanks for your patience and we apologize for any inconvenience.
Posted almost 3 years ago. Jun 09, 2016 - 12:49 EDT
Identified
We've identified and corrected the issue.
Mail is currently dequeueing, so delays are still processing.
We will update once the queues are back to normal.
Posted almost 3 years ago. Jun 09, 2016 - 10:05 EDT