Dashboard and Notifications
Incident Report for ReviewMonitoring.com
Resolved
We are back online. Thank you for your patience.
Posted Oct 13, 2016 - 08:58 EDT
Identified
We have received reports that some of our customers can not access the Dashboard and are experiencing latency issues. We are aware of the issue and are working to resolve it as quickly as possible. As more information becomes available we will update this Status post.
Posted Oct 13, 2016 - 08:42 EDT