Dashboard Affected
Incident Report for ReviewMonitoring.com
Resolved
We have identified and resolved the issue. We are back to full speed. Thanks for your patience, and we apologize for any inconvenience.
Posted 8 months ago. Dec 19, 2018 - 11:37 EST
Identified
We have received reports that some of our customers are experiencing latency issues. We are aware of the issue and are working to resolve it as quickly as possible. As more information becomes available we will update this Status post.
Posted 8 months ago. Dec 19, 2018 - 11:15 EST
This incident affected: Management Dashboard.