Email Processing Delays - Transactional Email Affected

Incident Report for ReviewMonitoring ReviewsAI

Resolved

The issue causing delays in transactional email processing has been fully resolved. All systems are operating normally. We will continue to monitor performance as part of our standard procedures.

Thank you for your patience and understanding.
Posted May 29, 2025 - 11:43 EDT

Monitoring

A fix has been implemented and transactional email processing is returning to normal. We are currently monitoring the system to ensure stability.
Posted May 28, 2025 - 22:40 EDT

Identified

We’ve identified the cause of the delays in transactional email processing. Our team is working on a fix and will provide updates as progress is made. Thank you for your patience as we work to resolve the issue.
Posted May 28, 2025 - 16:37 EDT

Investigating

We are currently investigating an issue causing delays in the processing of transactional emails. This may result in emails taking longer than expected to be delivered. Our team is actively working to identify the root cause and implement a solution.
Posted May 28, 2025 - 16:36 EDT
This incident affected: Alerts and Notifications.